Настройка PPPoE для маршрутизаторов Cisco

Одним из популярных сопособов подключения среди провайдеров Интернет является — PPPoE (Point-to-Point Protocol over Ethernet). Рассмотрим его настройку на маршрутизаторах Cisco. Данный способ справедлив правктически всех маршрутизаторов с современным IOS (я использовал Cisco 2821).

Итак, в моем случае кабель Ethernet от провайдера подключается к порту GigabitEthernet0/0, а локальная сеть подключена к GigabitEthernet0/1.

Конфигурация порта, подключенного к сети провайдера выглядит следующим обарзом:

interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1

В строках №5 и №6 разрешаем дозвон по PPPoE только с нашего интерфейса GigabitEthernet0/0.

Настроим порт для подключения к нашей локальной сети:

interface GigabitEthernet0/1
ip address 192.168.0.1 255.255.255.0
duplex auto
speed auto
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1412

В строке №5 маркируем интерфейса как внутренний для NAT, в строке №7 устанавливаем максимальный размер сегмента, чтобы не было проблем с прохождением фрагментированного траффика.

Теперь нам необходимо создать и сконфигурировать интерфейс для дозвона:

interface Dialer0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentification chap callin
ppp chap hostname login
ppp chap password 7 password

В строке №2 указываем, что ip адрес будет получен от провайдера. В строке №4 помечаем наш интерфейс как внешний для NAT. В строках с №9 по № 11 настраивается CHAP аутентификация, обратим внимание на строку №11 — пароль не будет отражаться открытым текстом.

Добавим маршрут по умолчанию:

ip route 0.0.0.0 0.0.0.0 Dialer0

Создадим ACL для натирования траффика из нашей локальной сети:

access-list 101 permit ip 192.168.0.0 0.0.0.255

Включим NAT:

ip nat inside source list 101 interface Dialer0 overload

Разрешим дозвон для ip траффика:

dialer-list 1 protocol ip permit

На этом процесс настройки подключения PPPoE к провайдеру Интернет закончен.

Отдельно хочется обратить внимание, что провайдер может использовать для аутентификации протокол PAP, в таком случае строки с №9 по №11 конфигурации интерфейса Dialer0 будут заменены на следующие:

ppp authentication pap callin
ppp pap sent-username login password 0 password

Так же следует отметить, что мы заранее разрешили PPPoE только на интерфейсе GigabitEthernet0/0, в некоторых случаях Вам может потребовать разрешить его глобально, для этого создадим следую группу дозвона:

vpdn-group PPPoE
request-dialin
protocol pppoe

Из конфигурацци интерфейса GigabitEthernet0/0 удалим строку №5, вместо нее добавим глобально следующее:

vpdn enable
vpdn ip udp ignore checksum

На этом все, мы рассмотрели все наиболее важные моменты, связанные с созданием подключения PPPoE. Надеюсь, что у Вас не вызовет никаких затруднений повторить это на Вашем оборудовании!